博客文章已转移到新地址,本地址暂时保留,新文章仅在新地址更新。[置顶]

gromacs5.x 在amd上安装问题

作者:小宝 2017-03-06 03:03:20

尴尬的事总会发生,我说说我在自己电脑安装gromacs的尴尬事情:

首先是各种尝试安装始终失败,不管是ubuntu 还是centos7,又或者linux mint 等,结果都失败了,不是FFTW问题就是CMAKE或者环境配置问题。

好不容易安装好了gromacs5.0.6,然后进行测试,结果出现一堆错误,都是amd的问题!

-DGMX-SID改成SSE4.1后前面都没有问题。到
gmx mdrun -deffnm md_0_1 这一步直接把内存消耗完了!系统一度卡死!目有办法啊,继续查看官方的文件,发现要用
AVX_128_FMA这个才比较合理。于是又重新编译我的gromacs了!过程很漫长,这个过程只能玩玩vi了!
看到官方的说法:
AVX_128_FMA AMD bulldozer processors (2011) have this. 
Unfortunately Intel and AMD have diverged the last few years;If you want good 
performance on modern AMD processors you have to use this since it also allows the
 reset of the codeto use AMD 4-way fused multiply-add instructions. The drawback is 
that your code will not run on Intel processors at all.
心累!好吧,不在INTEL的处理器执行好了! 
©BRISKLAN;备案信息:桂ICP备16004757号-1